@lalamax3d said in ubuntu 18 vestacp ssl giving error: lets encrypt, it gives 400 error hello can you provide some more information about webservers you're using it is nginx only or nginx + apache? BTW, have used previously ( cpanel, webmin, cwppro etc ) really loved its simplicity and speed. wanted to use it on new vps, but it seems stucked. confused about removing panel and os and install centos again or fight this problem or also considering hestiacp or aapanel. use CWP pro they have everything including mail server, reseller module, webservers (even litespeed), php (fpm and cgi multi php), and yes to install a control panel you need to reinstall of server OS since all are needed a clean os.