• I got this error when I tried use command: service httpd start

    Starting httpd: [Fri Jan 31 22:43:37 2020] [warn] module ruid2_module is already loaded, skipping
    httpd: Could not reliably determine the server’s fully qualified domain name, using server.xxx for ServerName

    My OS: CENTOS 6 with VestaCP

  • do you've mod ruid2 config file anywhere and whats in it ?

  • @sandeep thank you again for your help :). I don't modify anything in ruid2 config file so I'm not sure what wrong and where to find error log relate with this error to debug it.

  • Kindly send the output for this commands

    ls -la /etc/httpd/conf.d
    ls -la /etc/httpd/conf

  • @sandeep Ohh, sorry, I missed your notification.

    For the first output:

    total 68
    drwxr-xr-x 2 root root 4096 Jan 31 22:42 .
    drwxr-xr-x 4 root root 4096 Sep 22  2016 ..
    -rw-r--r-- 1 root root  126 Sep 22  2016
    -rw-r--r-- 1 root root  455 Oct  8  2013 fcgid.conf
    -rw-r--r-- 1 root root 2734 Sep 22  2016 mod_extract_forwarded.conf
    -rw-r--r-- 1 root root 1085 Mar 18  2015 mod_ruid2.conf
    -rw-r--r-- 1 root root 1675 Jan 21 18:43 php.conf
    -rw-r--r-- 1 root root 1017 Nov 18  2012 phpMyAdmin.conf.rpmsave
    -rw-r--r-- 1 root root    1 Sep 22  2016 proxy_ajp.conf
    -rw-r--r-- 1 root root  392 Nov 15  2012 README
    -rw-r--r-- 1 root root  278 Nov 18  2012 roundcubemail.conf.rpmsave
    -rw-r--r-- 1 root root  176 Jan  8  2015 ruid2.conf
    -rw-r--r-- 1 root root  406 Jun  4  2015 ssl.conf
    -rw-r--r-- 1 root root  153 May 13  2013 status.conf
    -rw-r--r-- 1 root root  308 Jan 11 04:50 vesta.conf
    -rw-r--r-- 1 root root  352 Sep  9  2004 webalizer.conf
    -rw-r--r-- 1 root root  299 Feb  7  2012 welcome.conf

    And for the next output:

    total 32
    drwxr-xr-x 2 root root  4096 Sep 22  2016 .
    drwxr-xr-x 4 root root  4096 Sep 22  2016 ..
    -rw-r--r-- 1 root root  7737 Mar 22  2013 httpd.conf
    -rw-r--r-- 1 root root 13139 Nov 15  2012 magic

    Thank you so much for your time and have a great week.

  • @Locvps said in Service httpd start error:


    edit the mod_ruid2.conf config under conf.d and comment out the load module line

    and for servername add

    ServerName hostname
    ServerName localhost

    in httpd.conf and restart httpd.

  • @sandeep I tried take a look in: mod_ruid2.conf and seem this line:

    LoadModule ruid2_module modules/mod_ruid2.so

    Already comment out, so I go to: httpd.conf and added:

    ServerName hostname

    It's look like that in my file:

    ServerTokens OS
    ServerRoot "/etc/httpd"
    PidFile run/httpd.pid
    Timeout 30
    KeepAlive Off
    MaxKeepAliveRequests 100
    KeepAliveTimeout 10
    ServerName hostname

    When I tried stop and start httpd, I got the output:

    service httpd start
    Starting httpd: [Wed Feb 12 20:28:31 2020] [warn] module ruid2_module is already loaded, skipping

    So is it already good now? If it's, I guess it's ok to overlook on it. But I have a curios, the first time I used stop or start httpd and I don't face this problem, but it's happened all of sudden, not sure what is problem, maybe it's relate to the ssl setup and specific to ssl let's encrypt (maybe)?

  • @Locvps said in Service httpd start error:

    comment out

    you need to add "#" before load module. and then restart httpd

    #LoadModule ruid2_module modules/mod_ruid2.so

  • @Locvps this are not any issue mod ruid2 is enabled two times may be in mod_ruid2.conf and in httpd.conf too. Updates can cause this.

  • @sandeep thank you so much, I follow all your instructions and all of it work well now.

    P/S: I tried restart httpd but it show restart: Unknown job: httpd. Maybe we must run full cmd instead:

    service httpd stop
    service httpd start

  • try
    service httpd reload

Recent Topics